Autoprefixer для Sublime text в Debian

Для Sublime Text есть замечательный плагин, который добавляет вендорные префиксы всем css-свойствам, где это необходимо.

Если у Вас операционная система Debian, то работать этот плагин не будет. При его вызове возникает ошибка и плагин не работает.

Решение есть и оно под катом.

У меня возникала ошибка вида:

Autoprefixer Error:
/home/user/.config/sublime-text-2/Packages/Autoprefixer/node_modules/get-stdin/index.js:7
return new Promise(function (resolve) {
...

Решение оказалось простым!

В своей работе плагин Autoprefixer для Sublime text использует nodejs версии 0.12 или выше. В родном Debian он есть, но версия его 0.10. Необходимо установить новую версия и пользоваться благами человечества.

Для установки nodejs версии 0.12, необходимо подключить сторонний репозиторий и установить с него nodejs:

curl -sL https://deb.nodesource.com/setup_0.12 | sudo bash -
sudo apt-get install -y nodejs

Всё оказалось проще, чем можно представить.

Комментарии:

Имя
e-mail
Сайт
Текст комментария: